Архив метки: OLT

PON: OLT BDCOM P3310B – Как посмотреть

Системаbdcom

Посмотреть загрузку CPU (секунда/минута/5 минут):
show cpu

Посмотреть локальных пользователей:
links — кол-во залогиненых под пользователем сессий
show local-users

Посмотреть MTU:
show system mtu

Версии

Посмотреть версию прошивки OLT:
здесь же можно глянуть и uptime
show version

Посмотреть версии прошивок зарегистрированых ONU (всех ONU за всеми EPON-портами):
show epon onu-software-version

Посмотреть версии прошивок зарегистрированых ONU (всех ONU за конкретным EPON-портом):
show epon onu-software-version interface EPON 0/1

Посмотреть версию прошивки конкретной ONU:
show epon interface EPON 0/1:2 onu ctc basic-info

Интерфейсы

Посмотреть статус и дескрипшины интерфейсов:
show interface brief

Посмотреть информацию о всех зарегистрированых ONU:
show epon onu-information

Посмотреть только активные ONU:
show epon active-onu

Посмотреть только неактивные ONU:
show epon inactive-onu

ONU

Посмотреть статус Ethernet-порта на ONU:
show epon interface epON 0/1:2 onu port 1 state

Посмотреть статистику по пакетам на Ethernet-порту на ONU:
show epon interface epON 0/1:2 onu port 1 statistics

Посмотреть таблицу mac-адресов на ONU:
show epon interface epON 0/1:2 onu mac address-table

Вланы

Посмотреть базу вланов:
show vlan

Посмотреть влан по id:
show vlan id 100

Таблица MAC-адресов

Посмотреть MAC-адреса в влане:
show mac address-table dynamic vlan 100

Посмотреть MAC-адреса на интерфейсе:
show mac address-table interface EPON 0/1:2

Посмотреть количество  MAC-адресов на интерфейсах:
show mac address-table brief

Почистить таблицу MAC-адресов:
clear mac address-table dynamic

Мощность сигнала

Посмотреть уровень получаемого сигнала от OLT к ONU (received power(DBm)),
Посмотреть мощность передатчика ONU(transmitted power(DBm)):

show epon interface EPON0/1:2 onu ctc optical-transceiver-diagnosis

Посмотреть уровни получаемого сигнала от всех зарегистрированых ONU к OLT (RxPower(dBm)),
Посмотреть мощность передатчика OLT (TxPower(dBm)):

show epon optical-transceiver-diagnosis

PON: OLT BDCOM P3310B — Базовая настройка

bdcomДефолтные настройки OLT BDCOM P3310B:

  • логин/пароль — admin/admin
  • management vlan 1
  • ip-address 192.168.0.1/24
  • Gigabit Ethernet и Epon порты выключены

 

1. Создание Management vlan 100

no interface vlan 1

interface vlan 100
description -= MANAGEMENT =-
ip address 192.168.100.2 255.255.255.0

ip default-gateway 192.168.100.1

Чтобы установить управляющий влан, отличный от vlan 1, для начала необходимо его (vlan 1) удалить, а затем уже прибивать свой.

 

2. Настройка Ethernet-интерфейсов

По умолчанию все порты shutdown.

interface gigaEthernet 0/1
description -= UPLINK =-
no shutdown
switchport mode trunk
switchport trunk vlan-allowed add 100,200,300

— поднимаем порт, переводим в режим trunk и добавляем необходимые вланы.

! Будьте осторожны при добавлении вланов в trunk — не забудьте слово add перед номерами вланов, иначе, все, что у вас было до добавления потрется и останется на порту только один (последний добавленный влан).

 

3. Настройка доступа

3.1 Создание пользователя

aaa authentication login default local
aaa authentication enable default enable — запрашивать enable-пароль на доступ к привилегированному уровню
username admin password 0 this_is_admin_password
enable password 0 this_is_ebable_password
service password-encryption
 

3.2 Access-list на telnet

Создаем access-list и вешаем его не на line vty 0 4 (или vty 0 31), как в cisco, а на «протокол доступа», точнее процесс telnet или ssh:

ip access-list standard MANAGEMENT
permit reverse-mask 192.168.100.0 0.0.0.255

— можно задать обратную маску, как в cisco, используя слово reverse-mask, а можно задать обычную:

permit 192.168.100.0 255.255.255.0

И вешаем access-list на telnet:

ip telnet access-class MANAGEMENT

 

4. Настройка времени

time-zone Kyiv +2
sntp server 192.168.100.1

 

5. Настройка SNMP

snmp-server location Zhukova,33
snmp-server contact admin@mail.com
snmp-server community public ro MANAGEMENT

— разрешить опрашивать OLT с коммьюнити public, доступ read-only, +защита аксес-листом MANAGEMENT

 

6. Hostname и banner

hostname my-switch
no banner message
banner message
text Hello admin!

text — это команда, указывающая на то, что далее следует само приветствие. Если нужен многострочный баннер — пишем его по строке, перед каждой строкой указываем text.

 

7. Настройка Epon

interface EPON0/1
description -= TREE 1 =-
switchport mode trunk
switchport trunk vlan-allowed 200,300

— здесь можно заметить, что не было использовано слово add перед вланами, это нормально, поскольку это первое добавление вланов. В последующем add обязательно!

Просмотр зарегистрированных ONU:

show epon onu-information
Interface EPON0/1 has registered 2 ONUs:
IntfName   VendorID  ModelID  MAC Address    Description     BindType  Status
Dereg Reason
———- ——— ——— ————— ————— ——— ———
—— ——————
EPON0/1:1  —-      —-     a0c6.ec33.1234 N/A             static    lost
unknow
EPON0/1:2  BDCM      151C     fcfa.f7ab.1234 N/A             static    autoconf
igured N/A

Чтобы вывод красиво умещался на консоли, правим настройки:

line console 0
length 0
width 256

show epon onu-information
Interface EPON0/1 has registered 2 ONUs:
IntfName VendorID ModelID MAC Address Description BindType Status Dereg Reason
———- ——— ——— ————— ————— ——— ————— ——————
EPON0/1:1 —- —-a0c6.ec33.1234 N/A static lost unknow
EPON0/1:2 BDCM 151Cfcfa.f7ab.1234 N/A static auto_configured N/A

 

8. Настройка ONU

interface EPON0/1:2
description -= CLIENT300 =- — этот description отображается в выводе «show interface  brief»
epon onu description CLIENT300 — а этот — в выводе команды «show epon onu-information»
epon onu all-port ctc vlan mode tag 300

— настраиваем все Ethernet-порты на ONU в режим (по-цисковски) access в влан 300. На Epon-порт ONU трафик приходит тегированный (вспоминаем настройку порта EPON0/1)

При подключении ONU, она сама регистрируется на OLT и доступна через назначеный ей LLID. LLID назначается следующий свободный, здесь он равен 2. EPON0/1:2 — интерфейс, определяющий ONU, подключеную в первый Epon-порт; была подключена эта ONU по счету второй.

 

9. Шейпинг (полисинг)

interface epon0/1:2
epon sla upstream pir 10000 cir 1000
epon sla downstream pir 10000 cir 1000

pir- максимальная скорость в Kb
cir- гарантированная скорость в Kb

— на тесте при установке вот таких значений были потери до 15% и задержки до 300 мс. Почему? пока неясно, будем тестить дальше.

при установке вот таких значений

epon sla upstream pir 100000 cir 1000
epon sla downstream pir 100000 cir 1000

все ок

! SLA используется для нарезки канала на ONU в целом

Rate-limit

— если ONU несколько-портовая, можно регулировать rate-limit на каждом отдельном порту:

epon onu port 1 ctc rate-limit 1000

rate-limit < sla = rate-limit
rate-limit > sla = sla

если оба значения выставлены — берется меньшее значение.

 

10. Loopback Detect

epon onu all-port loopback detect

отключать ONU, на которой была обнаружена петля.

Тест: к ONU подключили свитч, на свитче устроили петлю, loopback detect работает!

sMay 15 09:57:10 %LOOPBACK-DETECT: Line on Interface EPON0/1:1 onu uni 0, loopback is detected
show epon interface ePON 0/1:1 onu ctc bMay 15 09:58:30 %LOOPBACK-CLEAR: Line on Interface EPON0/1:1 onu uni 0, loopback is cleared

 

11. Как отвязать ONU

interface EPON0/1
no epon bind-onu sequence 1

— отвязать ONU на ветке 1, номер 1.

interface EPON0/1
no epon bind-onu mac xxxx.xxxx.xxxx

— отвязать ONU на ветке 1, с mac’ом  xxxx.xxxx.xxxx

PON: OLT BDCOM P3310B — Обновление прошивки

bdcom_logo

Обновление прошивки производится посредством tftp. Необходимо будет пройти следующие шаги:

  1. Скачиваем новую прошивку с источника в директорию на tftp-сервер.
  2. Бекапим старую прошивку (на всякий случай) с OLT на tftp-сервер.
  3. Удаляем старую прошивку с OLT.
  4. Заливаем новую прошивку с tftp на OLT.
  5. Перезагружаем OLT.

 

1. Скачиваем новую прошивку на tftp-сервер

 

Необходимую прошивку можно поискать здесь — http://ic-line.ua/ua-pon

P3310B_en_22960.bin — firmware для BDCOM P3310B Build 22960

 

2. Бекапим старую прошивку с OLT на tftp-сервер

 

Дефолтные настройки OLT BDCOM P3310B:

  • логин/пароль — admin/admin
  • management vlan 1
  • ip-address 192.168.0.1/24
  • Gigabit Ethernet и Epon порты выключены

 

Подключаемся к консоли с помощью какого-либо эмулятора терминала (у меня picocom) и консольного кабеля, который идет в комплекте с OLT:

Версия на текущий момент:

 

Подготовим OLT для связи с tftp-сервером

Как вы знаете, устройство, которое необходимо перепрошивать и tftp-сервер должны быть в прямой видимости между собой, т.е. в локальной сети.

Если вам необходимо сменить ip-адрес и управляющий влан (как мне), сначала необходимо удалить существующий:

Создаем новый management vlan 100 и прибиваем на него ip-address:

Нужно еще поднять порт Gigabit Ethernet 1 и добавить влан. GigabitEthernet подключен к транковому порту, поэтому управляющий влан 100 у меня приходит в теге:

 

Собственно, бекап

Посмотрим, что у нас на данный момент присутствует на Flash:

Switch.bin — это и есть та самая прошивка, которую нам необходимо заменить на более свежую.

Скопируем ее на tftp-сервер:

 

3. Удаление старой прошивки

 

В идеале было бы загрузить новую версию прошивки, не удаляя с флеши старую — и иметь на борту 2 версии. Но так не получится, поскольку банально на флеше нет столько свободного места, сколько требуется под еще одну прошивку. Вот и приходится производить лишние телодвижения:

 

4. Заливаем новую прошивку с tftp на OLT

 

В качестве Destination file name пишем Switch.bin:

 

5. Перезагружаем OLT

 

и смотрим результат: